Back to overview
Resolved
Server Update
Apr 30, 2026 at 2:00pm UTC
–
Apr 30, 2026 at 2:02pm UTC
Affected services
ChurchPath Platform Health
24-Hour DB Backup
Daily Notifications
Resolved
Apr 30, 2026 at 2:02pm UTC
Maintenance ended
Affected services
Created
Apr 30, 2026 at 2:00pm UTC
We are doing essential security updates. Normal service will resume shortly.
Affected services