Back to overview
Resolved

Just letting you know...

Mar 13, 2026 at 11:31pm UTC
Affected services
ChurchPath Platform Health

Resolved
Mar 13, 2026 at 11:31pm UTC

Our new status dashboard is up and running! We'll be using this to make sure the app is hitting its goals and keeping up and operational for you.